Commit e386268f authored by Alexandre's avatar Alexandre
Browse files

Use cpanm

parent 6071c228
Pipeline #6 failed with stage
in 4 minutes and 25 seconds
......@@ -11,16 +11,16 @@ test:
- export PERL5LIB=/usr/share/perl5
# Zonemaster LDNS needs a newer version of Module::Install
- cpan-install Module::Install Module::Install::XSUtil
- cpanm Module::Install Module::Install::XSUtil
# Zonemaster Backend transitively needs a newer version of Devel::CheckLib
- cpan-install Devel::CheckLib
- cpanm Devel::CheckLib
# Moose installed from OS packages depend on a newer version of Devel::OverloadInfo
- cpan-install Devel::OverloadInfo Moose
- cpanm Devel::OverloadInfo Moose
# IO::Socket::INET6 can't find Socket6 unless it's installed from CPAN
- cpan-install Socket6
- cpanm Socket6
# Install Zonemaster LDNS
- git clone --depth=1 --branch=develop https://github.com/zonemaster/zonemaster-ldns.git
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment